AUG
2
2007

oKular without PDF support (for me)

My freshly installed kde4-okular package (grabbed from the openSUSE build service repository, using the 'smart' package management tool) seems to be without PDF support.

It doesn't even display PDFs for selection in the FileOpen dialog. Cheating the filter line, by entering *.pdf makes the files show up -- but open they don't ("unsupported format").

I remember this was already the case when I had occasion to look at a KDE4 pre-Alpha build on a customer site 2 or 3 months ago. But now we have Cnuth, a 'Beta 1'. So I expected it to work, somehow....

pinotree told me on IRC that there should be a file named "$(kde4-config -prefix)/lib/kde4/libokularGenerator_poppler.so" on my system.

Well, on openSUSE 10-2 there is none. And not even in an different path either. And not in any of the packages that carry 'poppler' or 'okular' in their name (and I installed all of them).

So what is the solution?

Comments

It's a bug, so post a bug report. This isn't blog material.


By Jonathan Riddell at Thu, 08/02/2007 - 22:24

Fortunately, I'm still relatively free to decide when/how/where/what to write/vent in my blog...

What makes you think it's a bug, and not a missing installed package?


By Kurt Pf. at Thu, 08/02/2007 - 22:44

> What makes you think it's a bug, and not a missing installed package?

Jonathan is a distro guy, so missing dependencies would be a bug to him ;-)


By eike hein at Fri, 08/03/2007 - 20:38

"This isn't perfect right this second... "

http://dot.kde.org/1186051550/1186112789/


By Thomas Zander at Fri, 08/03/2007 - 06:40

I just had the same problem with self-compiled KDE4. No configure check or warning for missing libpoppler dev files... After reading this blog, I checked my installed packages and no libpoppler dev packages were installed, so of course the PDf part of okular could not be built!

There definitely needs to be some configure (ccmake) check and then a big, fat warning that PDF support will not be built. After installing the libpoppler-dev packages, the pdf generator for okular is really built.


By Reinhold Kainhofer at Sat, 08/04/2007 - 18:06

Okay, after installing libpoppler-dev, okular is able to open PDF files, but the filter in the open dialog does not offer *.pdf as a filter. You have to manually type *.pdf into the filter combo, then you can select the PDF files for opening...


By Reinhold Kainhofer at Sat, 08/04/2007 - 18:13