JAN
30
2006

korundum/qtruby compile 3.5?

The 3.5 branch of kdebinding doesn't compile and hasn't for a while I believe. It seems like the development of korundum/qtruby has moved to http://rubyforge.org/projects/korundum/.

I wonder why?

I copied some of the files from the latest release of korundum to kdebindings and it seems to compile (further) then it did.

smoke/qt just got done... smoke/kde is compiling...


M korundum/rubylib/rbkconfig_compiler/tests/Makefile.am
M kalyptus/ChangeLog
M kalyptus/kalyptusCxxToKimono.pm
M kalyptus/kalyptus
M kalyptus/kalyptusCxxToJNI.pm
M smoke/qt/header_list
M smoke/qt/Makefile.am
M smoke/qt/generate.pl.in
M smoke/qt/qtguess.pl.in

Comments

Uh? I'm quite sure it does work out of the branch, at least it does for 3.5.1 pre-release tarballs (I'm testing them here on Gentoo). In particular this revision solves the problems with Ruby 1.8.4 and adds the KDirOperator usage that was missing in 3.5.0.

I'm quite sure Richard still commits to branch-3.5 the fixes, and Caleb decided to leave the qtruby package for Gentoo to be built out of kdebindings instead of using the side-released version in rubyforge.


By Diego Elio Pettenò at Mon, 01/30/2006 - 06:39

I'm quite sure Richard still commits to branch-3.5 the fixes

Yes, absolutely - the KDE svn is where the commits go and where the latest version is, there is no change in policy.

If there are any problems with the build for KDE 3.5.1, then please either post a message on kde-bindings@kde.org, the RubyForge forum for the Korundum project or file a KDE bug report.


By Richard Dale at Mon, 01/30/2006 - 15:08

Well, O.K. then. I'll post my errors to kde-bindings...

Strange the kdebindings doesn't even come close to compiling for me...

korundum/rubylib/rbkconfig_compiler/tests/Makefile.am
still has the very old bug about the .SUFFIXES


By Kurt V. Hindenburg at Mon, 01/30/2006 - 15:53