SEP
13
2003

Kivio development

It's been a while since my last entry here, so I thought I'd tell everyone what I've been up to. :)

As there is a feature freeze right now I haven't commited anything, but I thought people wanted to know how things are progressing. :)

* Linestyles: The backend are implemented in 1.3, but I've added it to the gui localy (I didn't have time before the message freeze)

* Gradients: I have implemented support for filling stencils with gradients and pixmaps.

* Stencil rotation: This is my current project. (and it's a lot harder then I first thought!)

Comments

is there a solution to build Kivio add-ons (not stencils) like it is possible in Microsoft Visio.
If so it's the solution to develop kivio and bring it in new markets.

dseyaret@hotmail.com


By KDE User at Tue, 09/16/2003 - 09:36

Sure you can create your own plugins


By Peter Simonsson at Mon, 09/22/2003 - 20:15

Hi,

I'm using Kivio 1.3 on SuSE 8.2. I installed it fetching the
Koffice 1.3 RPMs and basically also upgrading KDE to 3.2 via
an extensive RPM party. Unfortunatedly KIVIO does everything except
the most important feature: connecting stencils. Simply no line
shows up. Instead a bunch of messages like:

QObject::connect: Cannot connect KStatusBarLabel::itemPressed(int) to (null)::pressed(int)
QObject::connect: Cannot connect KStatusBarLabel::itemReleased(int) to (null)::released(int)
QObject::disconnect: Unexpected null parameter
QRangeControl::setRange: minValue 0 > maxValue -59
QRangeControl::setRange: minValue 0 > maxValue -43
QRangeControl::setRange: minValue 0 > maxValue -29
kdecore (KAction): WARNING: KAction::updateShortcut(): name = "edit_undo", cut = Ctrl+Z; No KAccel, probably missing a parent co

does. Literally thousands...
I seriously doubt it is installed wrongly as some earlier versions
of kivio also spew tons of warnings/errors. But - at least they
did something.

Ciao


By rico at Mon, 03/15/2004 - 15:10

Hey Rico,

i just updated my Suse 9.0 desktop from KDE 3.1.4 to 3.2.2 and updated koffice to 1.3-70. Now i ran into the same problem with the connectors. Did you find a solution for ypour problem ? If yes please let me know.

thanks in advance
STEFAN aka whynot


By whynot at Wed, 04/28/2004 - 09:38

I am desperately waiting for SVG support! Is there something in the making or some other way to get SVG output (maybe via importing into another KOffice app)?

Thanks,
Martin


By djmaze at Mon, 07/18/2005 - 15:50